(напишите программу которая преобразует угол из градусной меры в радианную. результат выводится на экран) в pascal abc

evgenscorp1 evgenscorp1    3   08.07.2019 17:10    2

Ответы
dogs2247 dogs2247  30.08.2020 14:21
//PascalABC.Net 3.0, сборка 1052
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',DegToRad(d))
end.

Тестовое решение:
Введите угол в градусах: 57.3
Угол в радианах: 1.00007364807695

Вариант с формулой вместо функции:
//PascalABC.Net 3.0, сборка 1052
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',Pi*d/180)
end.

Вариант, если не хочется использовать константу Pi:
//PascalABC.Net 3.0, сборка 1052
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',ArcTan(1)*d/45)
end.

Вариант для тех, кто не помнит, что arctg(1)=π/4:
//PascalABC.Net 3.0, сборка 1052
const
  Pi=3.14;
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',Pi*d/180)
end.

Тестовое решение для этого случая:
Введите угол в градусах: 57.3
Угол в радианах: 0.999566653357612

Как видно, из-за значения π, заданного с низкой точностью, снизилась и точность результата.
ПОКАЗАТЬ ОТВЕТЫ
Olya10783 Olya10783  30.08.2020 14:21
Var s:real;d:double;
begin 
Read(s);
d:= s*3.2425926/180;
write(s,' градусов = ',d,' радиан');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика