Напишите программу, которая предложит пользователю ввести длину строки n и ее члены-целые числа, и отобразит на экране следующую информацию: сам массив, среднее арифметическое всех четных чисел

Degradant81 Degradant81    2   02.10.2019 07:01    2

Ответы
Remus1 Remus1  11.08.2020 11:01

javascript:var n = prompt("Введите n:"), массив = [], чётных = 0; for (let сч = 0; сч < n; сч++) массив.push(parseInt(prompt("["+сч+"]:"))); alert(массив + "\n" + (массив.reduce(function (пр, тек) { if (тек % 2 == 0) { чётных++; return пр + тек; } else return пр; }, 0) / чётных));

ПОКАЗАТЬ ОТВЕТЫ
artemka106 artemka106  11.08.2020 11:01

var a:array of integer;

n,i,s,k:integer;

begin

write('Введите количество элементов массива: ');

readln(n);

a:=new integer[n];

for i:=0 to n-1 do read(a[i]);

write ('Массив: ');

for i:=0 to n-1 do write(a[i],'  ');

writeln;

for i:=0 to n-1 do

if a[i]mod 2 = 0 then

begin

s:=s+a[i];

k:=k+1

end;

writeln('Среднее арифметическое чётных элементов массива равно: ',s/k:0:3)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика