Напишите программу, которая позволит проверять пароль на сложность.
Проверку пароля следует проводить по таким критериям:
1. Длина: от 5 символов.
2. Буквы латинского алфавита в верхнем и нижнем регистре: A, a, Z, z.
3. Цифры: от 0 до 9.
4. Символы: @, #, %, &.
Рекомендации
Можете воспользоваться методом isnumeric() для проверки строки на наличие цифр. Метод isupper() позволяет
выполнить проверку букв в верхнем регистре, islower()
следует использовать для проверки нижнего регистра. В свою
очередь, isalpha() позволит определить символ в строке.

victoriabetenecova victoriabetenecova    3   09.10.2020 21:01    5

Ответы
nikskrypkin nikskrypkin  09.10.2020 22:01

python

import string

lower = list(string.ascii_lowercase)

upper = list(string.ascii_uppercase)

digits = ['0','1','2','3','4','5','6','7','8','9']

characters = ['@', '#', '%', '&']

password = input('Введите пароль: ')

password_difficulty = 0

for i in lower:

 if i in password:

   password_difficulty += 1

   break

for i in upper:

 if i in password:

   password_difficulty += 1

   break

for i in digits:

 if i in password:

   password_difficulty += 1

   break

for i in characters:

 if i in password:

   password_difficulty += 1

   break

print(f'Сложность пароля: {password_difficulty}')

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика