Напишите программу, которая позволит определить количество дней в течение заданного периода, в которые не было прибыли, и максимальную выручку за этот период. прибыль за день определяется как разность "выручка"-1000 (рублей) (если разность отрицательна, считать прибыль равной 0). на входе программа получает период n

julia00221 julia00221    2   31.03.2019 16:10    6

Ответы
rrrl1 rrrl1  27.05.2020 23:54

через генератор случайных чисел
program noname;
uses crt;
var
n,k,i:integer;
a:array[1..1000] of longint;
max:longint;
begin
clrscr;
write('vvedi period n=');
readln(n); k:=0;
for i:=1 to n do begin
randomize;
a[i]:=random(10000);
writeln(a[i]);
if a[i]-1000<0 then k:=k+1;
end;
max:=a[1];
for i:=2 to n do
if max<a[i] then max:=a[i];
writeln(k,'-дни без прибыли ',max,'-максимальная выручка');
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика