Напишите программу которая получает возраст человека и выводит его возраст со словами: год,года или нужно) но программа должна быть простая,так как я учусь в соц.гуме)

Дженнифер878 Дженнифер878    2   02.06.2019 06:00    3

Ответы
grachikovaleksei grachikovaleksei  03.07.2020 01:44
Var
 n:integer;
begin
 readln(n);
 if (n mod 10 = 1) and ((n mod 100) div 10<>1) then
  writeln(n,' год')
 else
  if ((n mod 10 = 2) or (n mod 10 = 3) or (n mod 10 = 4)) and ((n mod 100) div 10<>1) then
   writeln(n,' года')
  else
   writeln(n,' лет');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика