Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом «год», «года» или «лет». например, «21 год», «22 года», «25 лет». пример: введите возраст: 18 вам 18 лет. пример: введите возраст: 21вам 21 год. пример: введите возраст: 22вам 22 года. на c++ или паскаль

xXNASTYXx xXNASTYXx    3   01.10.2019 10:02    145

Ответы
0Pandohcka0 0Pandohcka0  09.10.2020 07:33

program Vozrasr;



var


 AGE: integer;//Переменная возраста



begin


 writeln('Введите любое число от 1 до 120');


 Readln(AGE); //Ввод возраста


 if (AGE < 1) or (AGE > 120) then


begin


   writeln('ERROR!')


end


 else


 begin


   case AGE of  //для чисел от 11 до 20 создаем отд-ый кейс


     11..20: Writeln('ответ: Мне ', AGE, ' лет');


   Else    //иначе если они не входят в диапазон от [11..20], то выполняется второй кейс


     begin


       case AGE mod 10 of     //делим на 10 и получаем остаток =


         1: Writeln('ответ: Мне ', AGE, ' год');


         2..4: Writeln('ответ: Мне ', AGE, ' года');


         0, 5..9: Writeln('ответ: Мне ', AGE, ' лет');


       end;


     end;


   end;


end;


end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика