Напишите программу, которая получает на вход три вещественных числа и находим сумму положительных из них. обьясните каждую строку.

двоечник60 двоечник60    1   08.10.2019 15:10    6

Ответы
mazyrovavlada mazyrovavlada  10.10.2020 04:34

Ну, наверное это должно выглядеть как то так. Я плохо помню паскаль

program Help;   #Заголовок

var  #Раздел с переменными

a, b ,c, summ : real;   #Входные переменные и по итогу их сумма, вещественные

begin  #Думаю понятно

   summ := 0;   #Инициализация summ, ибо статическая типизация

   writeln('Enter nums');   #Программа попросит ввести числа

   readln(a);  #Считывание

   readln(b);  #Считывание

   readln(c);  #Считывание

   

   if a > 0 then summ += a;  #Если переменная а больше нуля, прибавляем её к итоговой переменной

   if b > 0 then summ += b;  #Аналогично

   if c > 0 then summ += c;   #Аналогично

   

   write(summ);   #Выводим переменную summ на экран

       

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика