Напишите программу, которая подсчитывает, сколько различных чисел содержится в данном списке. входные данные программа получает на вход несколько чисел (не более 1000), записанных в одной строке через пробел. все числа по модулю не превосходят . выходные данные программа должна вывести единственное число - количество различных чисел среди данных. пример ввод вывод 2 5 1 3 1 5 (python)

френкинштеин френкинштеин    3   27.09.2019 04:20    6

Ответы
lovedeutschlan lovedeutschlan  08.10.2020 21:52

Например, можно действовать так: сначала отсортировать массив, а затем пройти по нему, подсчитывая количество элементов, которые не совпадают со следующим за ним элементом.

a = list(map(int, input().split()))

count = 1

a.sort()

for i in range(len(a) - 1):

    if a[i] != a[i + 1]:

        count += 1

print(count)

Но проще всего преобразовать массив в множество (set):

a = set(map(int, input().split()))

print(len(a))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика