Напишите программу, которая по введённым с клавиатуры числам e, f и g будет вычислять значение коэффициентов a,b и c квдратного уравнения по предлагаемым формулам, а также значение дискриминанта d, решать это квадратное уравнение и выдавать результаты его решения. a=|e-f|(|e-f| - в третьей степени) b= корень из (3e + 17)(3e+17 - в четвёртой степени) c=(g-f): 144, где d=b(в квадрате) - 4ac, корни уравнения x1,2=(-b+- корень изd): 2a отладьте программу на следующем примере: e=2 f=-2 g=3 a=64 b=529 c=0,0347222 d=279832 x1=-6< 53267e-05 x2=-8,26556

ohotniktv509 ohotniktv509    3   11.03.2019 14:50    3

Ответы
Лемо4ик Лемо4ик  24.05.2020 21:24

var a,b,c,D,x1,x2:real;

e,f,g:integer;

begin

writeln("vvedite koefficienty: ");

read(e);

read(f);

read(g);

a:=sqr(abs(e-f))*abs(e-f);

b:=sqr(sqr(sqrt(3*e+17)));

c:=(g-f)/144;

D:=sqr(b)-4*a*c;

x1:=(-b+sqrt(d))/(2*a);

x1:=(-b-sqrt(d))/(2*a);

writeln("x1=",x1,"x2=",x2);

readln

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика