Напишите программу, которая по введенному не более, чем четырехзначному числу k будет выдавать сумму его цифр.

Sindex212 Sindex212    3   01.10.2019 18:40    10

Ответы
nargis84002 nargis84002  09.10.2020 10:10

var k:integer;

begin

write ('Введите не более, чем четырехзначное число: ');

readln (k);

writeln ('Сумма цифр равна: ',k div 1000 + k div 100 mod 10 + k mod 100 div 10 + k mod 10)

end.

ПОКАЗАТЬ ОТВЕТЫ
urasaya urasaya  09.10.2020 10:10

Держи на приличном языке:

javascript:var K = parseInt(prompt().substr(0, 4)), сумма = 0; while (K > 0) { сумма += K % 10; K = K / 10 | 0; } alert(сумма);

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика