Напишите программу, которая переводит число в 10-й с/с в 2-ую с/с через цикл while.

клим512 клим512    3   25.04.2021 14:24    3

Ответы
Azimhan2017 Azimhan2017  25.04.2021 14:30

#include "stdafx.h"

#include <iostream>

using namespace std;

 

int main() {

   setlocale(LC_ALL, "Russian");

   int n;

   cout << "Введите число" << endl;

   cin >> n;

   while (n > 0) {

   (n%2 == 0) ? cout << "0" : cout << "1";

   (n%2 == 0) ? n = (n) / 2 : n = (n-1) / 2;  

   }

   cout << endl;

   system("pause");

   return 0;

}

var ch,new,st_10:integer;

begin

 writeln('Введи число');

 readln(ch);

 st_10:=1;

 while ch<>0 do

 begin

  new:=new+(ch mod 2)*st_10;

  ch:=ch div 2;

  st_10:=st_10*10;

 end;

 writeln('Число в двоичной системе сч.- ',new);

end.

Объяснение:

1)язык c++, 2) Паскаль, поставь лайк )

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика