Напишите программу которая переводит число из 2-9 системы счисления в 10 на паскале


Напишите программу которая переводит число из 2-9 системы счисления в 10 на паскале

volchica232005 volchica232005    2   22.03.2022 13:38    2

Ответы
Анастасия11111127564 Анастасия11111127564  22.03.2022 13:40

Program From2To10;

var

n2: Longint;

n10, m, i: Integer;

begin

Write('n2 = ');

ReadLn(n2);

n10 := 0;

m := 1;

while n2 <> 0 do

begin

i := n2 mod 10;

n10 := n10 + i * m;

m := m * 2;

n2 := n2 div 10;

end;

WriteLn('n10 = ', n10);

end.

n2 - исходное число в двоичной записи

n10 - число в десятичной записи

m - 2 в степени номер разряда цифры

i - очередная цифра

Объяснение:

Вроде так

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика