Напишите программу которая определяет является ли заданное натуральное числом квадратом некоторого натурального числа

аоаоаоаоатте аоаоаоаоатте    2   30.07.2019 00:40    3

Ответы
ritagribaleva ritagribaleva  25.08.2020 16:20
Var
n, x: longint;
begin
readln(n);
x := round(sqrt(n));
if x * x = n then
writeln('YES')
else
writeln('NO');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика