Напишите программу,которая определяет количество отрицательных чисел среди трех введенных.

gardenberg17 gardenberg17    2   26.07.2019 12:10    1

Ответы
Король344 Король344  24.09.2020 22:15
//Постарался как можно проще
//Pascal ABC.NET v3.1 сборка 1219

Var
 a,b,c,k:integer;
begin
 read(a,b,c);
 if a<0 then k:=k+1;
 if b<0 then k:=k+1;
 if c<0 then k:=k+1;
 writeln(k);
end.

Пример ввода:
-1
4
-6
Пример вывода:
2
ПОКАЗАТЬ ОТВЕТЫ
fuguh fuguh  24.09.2020 22:15
Var
  i, k, n: integer;

begin
  for i := 1 to 3 do
  begin
    readln(n);
    if n < 0 then k := k + 1;
  end;
 
  writeln(k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика