Напишите программу, которая определит, каких букв в строке с русским текстом больше: «р» или «О» (см. пример 9.3). Пример 9.3.

V. Программа:

var St: string:

n, k1, k2: integer;

begin

writeln('Введите текст'); readln(St);

n := length(St); k1 := 0; k2 := 0;

for var i := 1 to n do

begin

if st[i] = '.' then

k1 := k1 + 1;

if St[i] = ',' then k2 := k2 + 1;

end;

if kl > k2 then

writeln('Точек больше)

else

if k2 > kl then

writeln('Зaпятых больше")

else

writeln('Количество запятых равно количеству точек');
очень надо

vdhfhsbh vdhfhsbh    3   26.11.2021 00:13    9

Ответы
Møŝķá56 Møŝķá56  31.12.2021 22:49

text = str(input())

if text.count('р') > text.count('О'):

print('больше - р')

elif text.count('р') == text.count('О'):

print('р = О')

else:

print('больше - О')

ПОКАЗАТЬ ОТВЕТЫ
lisi3 lisi3  31.12.2021 22:49

программа будет считать ВСЕ буквы O и  P, и заглавные и прописные.

Pascal

Объяснение:

var

 St: string;

 n, k1, k2, i: integer;

begin

 writeln('Введите текст'); readln(St);

 n := length(St); k1 := 0; k2 := 0;

 for i := 1 to n do begin

   if Uppercase(st[i]) = 'P' then inc(k1);

   if Uppercase(St[i]) = 'O' then inc(k2);

 end;

 if k1 > k2 then writeln('P больше')

 else

    if k2 > k1 then writeln('О больше')

 else  writeln('Количество P равно количеству O');

end.


Напишите программу, которая определит, каких букв в строке с русским текстом больше: «р» или «О» (см
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика