Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0( признак окончания ввода, не входит в последовательность). количество чисел не превышает 100. введенные числа по модулю не превышают 30000. программа должна вывести одно число: сумму чётных чисел, больше 5.

лиана249 лиана249    2   30.07.2019 07:50    6

Ответы
ghhhhd ghhhhd  27.09.2020 20:46
Var
    a: integer;
    s: longint;

begin
    s := 0;
    readln(a);
    
    while a <> 0 do
    begin
        if (a mod 2 = 0) and (a > 5) then
            s := s + a;
        readln(a);
    end;
    
    writeln(s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика