Напишите программу, которая находит среднее значение четных и нечетных чисел из одного файла и записывает ответ в другой файл ( из файла in.txt в out.txt) паскаль пример 6 - (кол-во чисел) 1 2 3 4 5 6 среднее значение чётных среднее значение нечётных

Hffjcdhudyhx Hffjcdhudyhx    2   27.07.2019 15:10    9

Ответы
АлёнаKet234 АлёнаKet234  25.09.2020 12:24
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var s:=ReadLines('in.txt').ToArray;
  var n:=StrToInt(s[0]);
  var a:=s[1].ToWords.Select(e->StrToInt(e)).ToArray;
  var f:=OpenWrite('out.txt');
  Writeln(f,n,' - (кол-во чисел)');
  foreach var e in a do Write(f,e,' '); Writeln(f);
  Writeln(f,'Среднее значение четных ',
    a.Where(x->x.IsEven).Average);
  Writeln(f,'Среднее значение нечетных ',
    a.Where(x->x.IsOdd).Average);
  f.Close
end.

Файлы in.txt и out.txt находятся во вложении.

Содержимое файла out.txt:
15 - (кол-во чисел)
-22 49 33 47 -10 -1 20 -18 2 21 2 -25 21 -47 -36
Среднее значение четных -8.85714285714286
Среднее значение нечетных 12.25
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика