Напишите программу, которая находит квадрат произведения цифр введенного числа

lubimka4 lubimka4    2   01.09.2019 07:10    2

Ответы
1988katerinkam 1988katerinkam  06.10.2020 09:16
Var a,p:integer;
begin
write('a = ');
readln(a);
a:=abs(a);
p:=1;
while a<>0 do
 begin
 p:=p*(a mod 10);
 a:=a div 10;
 end;
p:=p*p;
writeln('p = ',p);
end.

Пример:
a = 273
p = 1764
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика