Напишите программу, которая ищет среди целых числовому отрезку [185457;185489]


Напишите программу, которая ищет среди целых числовому отрезку [185457;185489]

Макс228336 Макс228336    3   07.04.2021 18:40    2

Ответы
OlessyaBaeva OlessyaBaeva  07.04.2021 18:50

Объяснение:

var b,i,x,j:integer;

s:string;

begin

for i:=185457 to 185489 do

begin

 x:=0;

 s:='';

 for j:=2 to (i div 2) do  

   if ((i mod j)=0) then begin

     x:=x+1;

     s:=s+j+' ';

     end;

   if x=2 then

     writeln (s,'\\ ',i);

 end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика