Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [244143; 367821], числа, имеющие ровно 5 различных делителей. выведите эти делители для каждого найденного числа в порядке возрастания.

ян6 ян6    3   12.04.2019 16:40    124

Ответы
dongrigoriew20 dongrigoriew20  12.04.2019 18:00

uses crt;

var i,sum,k: integer;

begin

      sum: =0;

      k: =0;

      writeln('вводите числа. 0 - конец последовательности');

      repeat

          read(i);

          if i mod 2=1 then begin

              sum: =sum+i;

              inc(k);

          end;

      until i=0;

      writeln;

      writeln('среднее  арифметическое нечетных чисел: ',sum/k: 5: 3);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика