Напишите программу , которая фармирует масси из n элементов ( максимальное количество элементов равно 20), значения элементов массива - случайные числа от -10 до 25 программа должна: 1) выводить на экран сначала все элементы массива, стоящие на четных местах, а зате - все элементы массива, стоящие на нечетных местах; 2) вывести на экран сумму всех элементов массива, значения которых кратны 3 или 5. 3) найти минимальное и максимальное значение элементов массива.

sapesalex sapesalex    3   26.05.2019 15:20    4

Ответы
buniatyansona buniatyansona  01.10.2020 12:14
Var
a:array[1..20] of integer;
i,n,min,max,s:integer;
begin
randomize;
s:=0;
writeln ('Введи кол-во элементов в массиве');
readln(n);
for i:=1 to n do
a[i]:=random(35)-10;
for i:=1 to n do
if i mod 2 = 0 then writeln ('a[',i,']=',a[i]);
for i:=1 to n do
if i mod 2 >0 then writeln ('a[',i,']=',a[i]);
for i:=1 to n do if (a[i] mod 3 = 0) or (a[i] mod 5 = 0) then s:=s+a[i];
writeln ('Сумма членов кратных 3 или 5 = ',s); 
min:=a[1]; 
max:=a[1]; 
for i:=2 to n do begin
 if a[i]<min then min:=a[i]; 
if a[i]>max then max:=a[i];
 end; 
writeln ('Максимум=',max); 
writeln('Минимум=',min); 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика