Напишите программу которая для заданного числа определит сколько понадобится спичек чтобы выложить все цифры числа входные данные 1 239 результат 2 16

Mimimishkaaaa Mimimishkaaaa    2   12.08.2019 08:00    1

Ответы
menshikovborisg menshikovborisg  04.10.2020 13:12
См. вложенный файл, программа в нём 
ПОКАЗАТЬ ОТВЕТЫ
vlad134631 vlad134631  04.10.2020 13:12
var a: array[0..9] of integer:=(6,2,5,5,4,5,6,3,7,6);
    i,s: integer;
    st: string;
begin
   write('число: ');  readln(st);
   s:=0;
   for i:=1 to length(st) do
   s:=s+a[ord(st[i])-48];
   writeln('число спичек = ',s);
end.

  
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика