tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу которая для
Напишите программу которая для введённой пары положительных чисел, большее число делит на меньшее до того, пока оно не станет меньше единицы
gggtair2004
2 16.09.2019 20:00
2
Ответы
Кристиночка0913
10.08.2020 21:23
П0 <-> П1 - x<0 13 ИП0 П2 ИП1 П0 ИП2 П1
ИП0 1 - x<0 22 ИП0 ИП1 / П0 ИП0 С/П
ПОКАЗАТЬ ОТВЕТЫ
raffigaz10
10.08.2020 21:23
Var
a,b,t:real;
begin
Write('Введите через пробел два положительных числа: ');
Read(a,b);
if b>a then begin t:=a; a:=b; b:=t end;
repeat
a:=a/b
until a<1;
Writeln(a)
end.
Пример
Введите через пробел два положительных числа: 1.7 153.4
0.760915000615007
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
zhuckovanatali1
07.05.2021 14:19
В любом трехзначном числе удалить среднюю цифру, а в оставшемся 2-х-значном числе переставить цифры. Вывести получившееся число. В Паскале...
didenkoelenam
07.05.2021 14:17
Дано целое пятизначное число, найти сумму 1 и 2 цифры, произведение 3 и 4 цифры, квадрат 3 цифры....
rinnavinn
19.10.2020 14:37
ASCII Какие виды кодирования ты знаешь? Как создаются таблицы кодирования? Какова функция таблиц кодирования? Какие таблицы кодирования можно привести из повседневной жизни?...
princess110
19.10.2020 14:46
Составить блок схему алгоритма запуска программы Word в ОС Windows 10. Предусмотреть ситуацию, когда программа не установлена на компьютер....
Maks2222222222
19.10.2020 14:39
Для удобства в таблице ASCII символы номеруются в системе счисления...
princhesnurss
19.10.2020 14:11
Сколько натуральных чисел расположено в интервале...
Свумпик
07.04.2021 13:37
Встроенные функции. Методы работы с электронными таблицами...
natali29111978
07.04.2021 13:37
Вести з клавіатури масив з 5 елементів знайти мінімальних з них...
Adele04
30.03.2019 14:30
Скорость передачи данных скоростного adsl соединения равна 1024000 бит/я, а скорость передачи данных через 3g-модем равна 512000 бит/с. определите на сколько секунд дольше...
lolkekcheburek2281
30.03.2019 14:30
Кнопка ce программы калькулятора предназначена для?...
Популярные вопросы
Проанализируйте предложения. В поле ввода запишите причастие (в той форме,...
1
Найдите третью сторну по двум известным...
1
Решите буду благодарен. Напишите цитатную характеристику 2-х героев произведения...
2
ТЕОРИЯ ВЕРОЯТНОСТИ а) Вероятность дождливого дня в октябре равна 0.8. Какова...
2
Чотири провідники з опором по 1,5 Ом кожний необхідно з єднати так, щоб...
3
Вычислить площадь фигуры ограниченной кривыми y=sin+2, y=0,x=0,x=p(Пи)...
2
Проделать гидролиз крахмала и доказать наличие продуктов реакции.Получить...
2
ОЧЕНЬ что такое анализаторы 2. значение анализаторов 3. строение и функции...
3
Откуда получился 2 год ,как его найти...
2
В любой ли плоский угол можно вписать окружность?...
1
ИП0 1 - x<0 22 ИП0 ИП1 / П0 ИП0 С/П
a,b,t:real;
begin
Write('Введите через пробел два положительных числа: ');
Read(a,b);
if b>a then begin t:=a; a:=b; b:=t end;
repeat
a:=a/b
until a<1;
Writeln(a)
end.
Пример
Введите через пробел два положительных числа: 1.7 153.4
0.760915000615007