Напишите программу, которая для произвольного четырехзначного натурального числа N Вычисляет:
А) произведение первой и последней цифры числа N;
Б) если число N нечетное - выводит новое число М, образованное из числа N путем
обмена местами двух последних цифр между собой (пример – было 1234, стало 1243).​

kozarmarjna15 kozarmarjna15    1   22.01.2021 19:21    6

Ответы
hyyeblan5577 hyyeblan5577  21.02.2021 19:22

var

       n, m: Integer;

       

begin

       Read (n);

       

       WriteLn ('Произведение первой и последней цифры числа ', n, ': ', (n div 1000) * (n mod 10));

       WriteLn;

       

       if Odd (n) then begin

               m := (n div 1000) * 1000 + (n div 100 mod 10) * 100 + (n mod 10) * 10 + (n mod 100 div 10);

               

               WriteLn ('Число ', n, ' нечётное, поэтому новое число равно: ', m);

       end;

end.        

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика