Напишите программу,которая для последовательности натуральных чисел выводит сумму всех входящих в последовательность чисел,кратных 3 и при этом меньших 150.программа получает на вход количество чисел в последовательности,а затем сами числа. количество чисел не превышает 100.введённые числа не превышают 300. программа должна вывести одно число-сумму вех входящих в последовательность чисел,кратных 3 и при этом меньших 150. входные данные: 3 33 6 270 выходные данные 42

Vlada0904 Vlada0904    1   07.10.2019 02:01    4

Ответы
begemot14 begemot14  17.08.2020 09:36

var a,i,k,sum:integer;

begin

read(a);

for i:=1 to a do begin

read(k);

if(k mod 3 =0)and(k<150)then sum:=sum+k;

end;

write(sum);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика