Напишите программу, которая для каждого из трех чисел, введенных чисел с клавиатуры пользователем, определяет является это число четным или нечетным, двузначное оно или нет и кратно ли оно 3.

kartew kartew    1   20.08.2019 19:10    2

Ответы
HELPLIZA1 HELPLIZA1  05.10.2020 07:52
//прога на Pascal`e
var
a: array of int64;
n: longint;
i : byte;
begin
write ('Введите кол-во чисел: ');
readln (n);
setLength (a, n);
for i:=0 to n-1 do
begin
write ('Введите ', i+1, ' число: ');
readln (a[i]);
end;

for i:=0 to n-1 do
begin
writeln ('');
writeln ('Число ', a[i], ':');
if (a[i] mod 2) = 0 then writeln ('Четное') else writeln  ('Нечетное');
if (a[i] mod 3) = 0 then writeln ('Кратно 3-ем') else writeln ('Не кратно 3-ем');
if (a[i]<10) or (a[i]>99) then writeln ('Не 2-значное') else writeln ('2-значное');
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы