Напишите программу, которая будет выводить на экран последовательность фибоначчи. первые два члена последовательности и количество выводимых на экран членов пользователь должен ввести с клавиатуры (c++)

Машуничка12 Машуничка12    3   15.09.2019 13:10    1

Ответы
Mint231 Mint231  16.08.2020 16:24
#include <iostream>
int main(){    int n;
    std::cin >> n;
    int a = 1;    int b = 1;
    for(int i = 0; i < n; i++)    {        std::cout << (i % 2 == 0 ? a : b) << std::endl;
        if(i % 2 == 0)            a += b;        else             b += a;    }
    return 0;}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика