Напишите программу, которая будет получать на вход число n и 3 символа, а затем рисует с списков квадрат nxn из этих 3 символов по правилам: по диагонали – символ 1; все, что над ним – символ 2; все, что под диагональю – символ 3. python!

anadtadiamoroso anadtadiamoroso    3   09.06.2019 06:37    2

Ответы
Arinka26052005 Arinka26052005  08.07.2020 07:15

#с списков так с списков

N = int(input())

a, b, c = input(), input(), input()

arr = [['' for j in range(N)] for i in range(N)]

for i in range(N):

   for j in range(N):

       if i == j:

           arr[i][j] = a

       elif j > i:

           arr[i][j] = b

       else:

           arr[i][j] = c

       print(arr[i][j], sep='', end='')

   print()

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика