Напишите программу, которая будет подсчитывать количество отрицательных и положительных введённых чисел с клавиатуры, подсчёт вести до тех пор пока не будет введён 0

yaroslavaaf yaroslavaaf    3   17.04.2019 11:48    1

Ответы
sashaorlov2006 sashaorlov2006  07.06.2020 18:15

Var a, k, n:integer;

Begin

Write ('Вводите числа') ;

K:=0;n:=0;

Read(a) ;

While a<>0 do begin

If a>0 then k:=k+1;

If a<0 then n:=n+1;

Read(a) ;

End;

Writeln('Положительных ', k) ;

Writeln('Отрицательных ', n) ;

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика