Напишите программу, которая будет менять местами в каждой строке двумерного массива минимальный и последний элемент.

iljarybackov20 iljarybackov20    3   26.09.2019 16:40    2

Ответы
Gancha163 Gancha163  08.10.2020 20:38
PascalABC.NET 3.4.0, сборка 1671 от 31.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в массиве:');
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(m,n,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  for var i:=0 to a.RowCount-1 do begin
    var row:=a.Row(i);
    var imin:=row.IndexMin;
    Swap(row[imin],row[row.High]);
    a.SetRow(i,row)
    end;
  Writeln('*** Полученный массив ***'); a.Println(4)
end.

Напишите программу, которая будет менять местами в каждой строке двумерного массива минимальный и по
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика