Напишите программу, которая будет менять местами цифры (единицы и десятки) в двузначных целых числах. Пример: 79 97

Alisa11221122 Alisa11221122    2   07.09.2020 20:51    30

Ответы
liliverbovetska liliverbovetska  15.10.2020 18:34

На питоне.

print(input("Введите двузначное число: ")[::-1])

Объяснение:

Используется срез строки.

ПОКАЗАТЬ ОТВЕТЫ
Алина06072003 Алина06072003  15.10.2020 18:34

var

a:integer;

b,c:integer;    

t:integer;

begin

 writeln('Введите двухзначное челое число');

 readln(a);

 if not((a>9)and(a<100)and(a mod 10<> 0))then

   writeln('ERROR');

 if (a>9)and(a<100)and(a mod 10 <> 0)then

 begin

   b := a div 10;

   c := a mod 10;

   t := b-c;

   if t<0 then a:=a+abs(t*10)+t

   else a:= a-t*10+t;

   writeln(a)

 end;  

 end.

Объяснение:

Данная программа написана на Pascal

В программе я также исключил все числа 10,20,30,40,50,60,70,80,90 , так как при смене местами числа будут получаться однозначные(1,2,3,4,5,6,7,8,9)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика