Напишите программу,которая a)выводит на экран один двухмерный массив(5*3),в котором вписаны целые числа в интервале от 50 до 100; b)в массиве находится клетка с наименьшим значением.показывает на экране.

Ddddd46763 Ddddd46763    3   02.10.2019 07:01    3

Ответы
пикча6 пикча6  09.10.2020 11:12

const n=5; m=3;


var a:array [1..n,1..m] of integer;


i,j,e:integer;


begin


for i:= 1 to n do


begin


for j:=1 to m do


begin


a[i,j]:=Random(51)+50;


write(a[i,j]:4)


end;


writeln;


end;


e:=a[1,1];


for i:= 1 to n do


for j:=1 to m do


if a[i,j]<e then e:=a[i,j];


writeln ('Наименьший элемент: ',e)


end.

ПОКАЗАТЬ ОТВЕТЫ
AlyaMrr AlyaMrr  09.10.2020 11:12
PascalABC.NET 3.4.2, сборка 1881 от 19.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := MatrRandom(5, 3, 50, 100);

 a.Println(4);

 var (p, i, j) := a.ElementsWithIndexes.MinBy(t -> t[0]);

 Writeln('Минимальный элемент a[', i + 1, ',', j + 1, ']=', p);

end.

Пример

 64  54  96  76  96  59  68  95  63  78  51  75  68  56 100Минимальный элемент a[4,2]=51
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика