Напишите программу, которая: а) определяет, есть ли среди цифр заданного целого трехзначного числа одинаковые; б) явл. ли число "перевертышем", т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево.

BayntuMix BayntuMix    1   15.06.2019 08:40    2

Ответы
danilsalnikov danilsalnikov  12.07.2020 14:48
А) Program cifr;
Uses crt;
var n,l:integer; s:string;
Begin
read(n);
str(n,s);
l:=length(s);
  if (s[1]<>s[2]) and (s[2]<>s[3]) and (s[1]<>s[3])
    then begin writeln('Одинаковых цифр нет') end
    else writeln('Одинаковые цифры присутствуют');
end.

Б) Program Stroke;
Uses Crt;
Var s: string; n,i,j,l: integer;
Begin
  ReadLn(n);
  str(n,s);
  l:=length(s);
  j:=0;
for i := 1 to l div 2 do begin
  if s[i]=s[length(s)-i+1]
    then j:=1 end;
if j=1 then 
    writeln('Да, число является палиндромом')
    else writeln('Нет, число не является палиндромом');
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика