Напишите программу к вообще не понимаю! заранее ! поставлю ответ лучшим! шоколадка стоит a рублей с копеек. какое наибольшее количество шоколадок можно купить за b рублей?

333399 333399    2   28.08.2019 09:10    3

Ответы
popovamelanaliceysi popovamelanaliceysi  09.08.2020 23:59
Program program1;
var
a, b, c, n: integer;
begin
writeln('Введите стоимость шоколадки:');
write('рублей и копеек через пробел: ');
readln(a, c);
write('Введите количество рублей, которые имеются у Вас: ');
readln(b);
if (a < 0) or (c < 0) or (c > 99) then
writeln('введите корректные данные')
else
begin
n := trunc(b / (a + c/100));
writeln(n, ' шоколадок');
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
yerizhevasofa yerizhevasofa  09.08.2020 23:59
Var
  a,b,c:integer;
begin
  Write('Сколько стоит шоколадка (руб коп)? ');
  Read(a,c);
  Write('Сколько у вас рублей? ');
  Read(b);
  Write('Вы можете купить шоколадок: ',
    (100*b) div (100*a+c))
end.

Пример
Сколько стоит шоколадка (руб коп)? 35 50
Сколько у вас рублей? 140
Вы можете купить шоколадок: 3
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика