Напишите программу к . найти количество отрицательных чисел, вводить пока не будет 3.

sashahyrik sashahyrik    1   24.09.2019 07:50    1

Ответы
1233456789 1233456789  08.10.2020 14:39
1) Программа будет запрашивать ввод новых чисел, пока он не введёт число 3:

var i,count,n: Integer;
begin
while i<>3 do
begin
writeln('Введите число');
readln(n);
if n<0 then inc(count);
i:=n;
end;
writeln('Кол-во: ',count);
end.

2) Программа будет запрашивать ввод чисел, пока отрицательные числа в сумме не будут равны числу 3:

var count,n: Integer;
begin
while count<>3 do
begin
writeln('Введите число');
readln(n);
if n<0 then inc(count);
end;
writeln('Кол-во: ',count);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика