Напишите программу информатика (75 )!
определить, верно ли, что при делении натурального числа a на натуральное число b получится остаток, равный числу c.

4iterok211 4iterok211    2   07.02.2020 21:28    3

Ответы
pinelike pinelike  11.10.2020 04:07

var

a,b,c,ostatok:integer;

cr:real;

begin

a:=5;

b:=3;

//Если использовать не целочисленного деление,

//то будет 1.666666666...

cr:=a / b;

 writeln ('При нецелочисленном делении c=',cr);

//Если использовать целочисленного деление,

//то будет 1

c:=a div b;

writeln ('При целочисленном делении c=',c);

//Проверим остаток при целочисленном делении арифметический

ostatok := a-c*b;

writeln ('При делении ',a,' на ',b,' остаток = ',ostatok);

//Проверим остаток при целочисленном делении с операции mod

ostatok := a mod b;

writeln ('При делении ',a,' на ',b,' остаток = ',ostatok);

end.

Объяснение:


Напишите программу информатика (75 )! определить, верно ли, что при делении натурального числа a на
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика