Напишите программу. группа студентов сдает экзамен. оценки формируются случайным образом от 2 до 5. напечатать кол-во полученых двок,трок,четверок,пятерок

sanzik2005 sanzik2005    1   19.06.2019 13:40    5

Ответы
myyllaas myyllaas  02.10.2020 05:27
Pascal

const  n = 10; //Кол-во студентов
//можно сделать с вводом с клавиатуры
    var  i,a : integer; 
 o : array[2..5] of integer; 
     begin 
randomize; 
 for i :=2 to  5 do 
  o[i] := 0;   
 
for i := 1 to N do 
 begin 
   a := 2 + random(4); 
   o[a] := o[a] +1; 
  end; 
 for i := 2 to 5 do 
  writeln (i,'=',o[i]); 
 end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика