Напишите программу формирования и вывода массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен сумме двух предыдущих элементов. два первых элемента задайте с клавиатуры. напишите программу формирования и вывода массива размером 6х3, каждые три последовательных элемента в строке которого составлены по следующему правилу: 1-й - равен случайному числу, отличному от нуля; 2-й - равен квадрату предыдущего элемента; 3-й - равен целой части частного от деления двух предыдущих элементов.

nast60 nast60    2   19.06.2019 08:40    2

Ответы
shapakinandrejozt2iy shapakinandrejozt2iy  15.07.2020 17:29
1. var a:array [1..100] of integer;
i,n:integer;
begin
read(n); {количество эл. массива}
read (a[1], a[2]);
for i:=3 to n do
a[i]:=a[i-1]+a[i-2];
for i:=1 to n do
write (a[i],' ' );
end.

2.const m=6;n=3;
var a:array [1..100,1..100] of integer;
i,j:integer;
begin
for i:=1 to m do
read (a[i,1]);
for i:=1 to m do
begin
j:=1;
a[i,j+1]:= sqr(a[i,j]);
a[i,j+2]:= a[i,j] div a[i,j+1]; {это условие мне не совсем понятно}
end;
for i:=1 to m do
begin
for j:=1 to n do
write (a[i,j]:3);
writeln;end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика