tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу для того,
Напишите программу для того, чтобы в целом натуральном числе n поменять местами первую и последнюю цифру, с цикла while в pascal abc. за него 15 . , !
dimon007228
3 02.06.2019 00:01
2
Ответы
pisturin
02.07.2020 22:31
Program chik;
var n,a,b,s,q,k:integer;
begin
readln(n);
q:=n mod 10;
while n>0 do
begin
b:=n mod 10;
n:=n div 10;
s:=s*10+b;
end;
n:=q;
s:=s div 10;
while s>10 do
begin
k:=s mod 10;
s:=s div 10;
n:=n*10+k;
end;
n:=n*10+b;
writeln(n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ladykrisMi
13.07.2019 05:00
Сколько символов содержит сообщение при информационном весе 32 байта,если при наборе испотзуется 16 символый алфавит информатика сколько количество символов в сообщении ?...
katya2562
13.07.2019 05:00
При каком формировании производится очистка только каталога диска...
DFSAFSA
13.07.2019 05:00
Аня случайно потеряла блокнот с записью электронного адреса почтового ящика саши. ей восстановить этот адрес, если известно имя почтового сервера (binary-digit), который находится...
Parastaev
13.07.2019 05:00
Увас есть три пользователя: виталий, андрей и павел, которые не дружат друг с другом. известно, что у виталия и андрея 50 общих друзей, у андрея и павла 91 общих друзей, а у павла...
pollllyyy
26.04.2020 14:10
Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет среднее арифметическое элементов этого массива....
adelina121212
26.04.2020 14:09
Https://thriveglobal.com/authors/full-free-watch-365-dni-days-2020-online-hd-free https://thriveglobal.com/authors/full-365-dni-days-2020-full-movie-at-online-free https://thriveglobal.com/authors/fullwatch-365-dni-days2020-online-full-movie-at-hd-online...
Alex1t0
29.04.2020 14:14
Задана матрица с максимальным размером 20х20. Строки заданной матрицы нужно переставить в порядке возрастания суммы элементов каждой строки. С клавиатуры задается актуальное количество...
NastiaKostiuk
16.04.2019 23:00
В опытах Резерфорда по рассеянию а-частиц при их прохождении через золотую фольгу было обнаружено, что только одна из примерно...
BPAN321
16.04.2019 23:00
Препарат активностью 1,7 *10^12 частиц в секунду помещён в медный контейнер массой 0,5 кг. На сколько повысится температура контейнера...
садов19
16.04.2019 23:00
В сосуде находится разреженный атомарный водород. Атом водорода в основном состоянии (Е1 = -13,6 эВ) поглощает фотон и ионизуется....
Популярные вопросы
зарубіжна література Твір Мініатюра ахіл гектор троянці най хоробріші...
2
Answers. What do you need 15. Write questions andto do this? Выбери нужные...
3
Төменде сабаққа үлгермеудің негізгі себептері көрсетілген. Аталған жағдайлар...
2
Решите номер 260 и только правильно и побыстрее до вечера Можно скинуть и фото...
2
В соединении Feх(III)О3(II) индекс х равен...
2
Какова роль восклицательных предложений в начале стихотворения зимнее утро...
2
Какое количество вещества водорода выделится при реакции 6,5 граммов цинка...
2
вставьте букву в двух словах:а) сверчок стереж_тБ) ж_рдочка ...
1
Як відбувається дихання рослин?Які орани беруть участь у диханн...
3
Найти 3 словосочетания (согласование,управление и привыкание) в упражнение...
2
var n,a,b,s,q,k:integer;
begin
readln(n);
q:=n mod 10;
while n>0 do
begin
b:=n mod 10;
n:=n div 10;
s:=s*10+b;
end;
n:=q;
s:=s div 10;
while s>10 do
begin
k:=s mod 10;
s:=s div 10;
n:=n*10+k;
end;
n:=n*10+b;
writeln(n);
end.