Напишите программу для решения следующей задачи. На контрольной работе по алгебре ученикам 9 класса было предложено 10 примеров. Неудовлетворительная оценка выставляется, если правильно решено менее половины примеров. Сколько неудовлетворительных оценок было получено учениками? Если хотя бы один из учеников правильно решил все задачи, выведите YES, иначе выведите NO. Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров.ЯЗЫК С+++

ilyamaximov514 ilyamaximov514    3   16.12.2020 16:33    29

Ответы
Авитя1 Авитя1  15.01.2021 16:33

var a,b,c,d,e:integer;

begin

d:=1;

e:=0;

writeln('введите количество учеников');

readln(a);

for b:=1 to a do begin

writeln('введите количество правильных ответов для ',d,' ученика' );

readln(c);

while (c>10) or (c<0) do begin

writeln('вы ввели неверное число, попробуйте снова');

readln(c);

end;

if c = 10 then e:=e+1;

d:=d+1;

end;

if (e>=1) then writeln('yes ')

else writeln('no');

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика