Напишите программу для решения следующей задачи дано целое число является ли оно четным?(C++)

ЛизкаПодлизка111 ЛизкаПодлизка111    3   26.02.2021 12:46    2

Ответы
Darina784 Darina784  26.02.2021 12:50

#include <iostream>

using namespace std;

int main(){

   int n;

   cin >> n;

   if ((n & 1) == 0)

       cout << "Четное";

   else

       cout << "Нечетное";

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Vampir181 Vampir181  26.02.2021 12:50

Код на C++:

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL, "rus");

   int n;

   cin >> n;

   cout << (n % 2 ? "Нечетное (Odd)" : "Четное (Even)") << endl;

   return 0;

}

Объяснение:

Элегантное и простое решение с использованием тернарного оператора

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика