Напишите программу для решения следующей .
ученики 4 класса вели дневники наблюдения за погодой и ежедневно
записывали дневную температуру. найдите среднюю температуру для дней,
когда столбик термометра поднимался выше нуля градусов. определите
количество таких дней. гарантируется, что за время наблюдения хотя бы
в один из дней температура поднималась выше нуля градусов.
программа получает на вход количество дней, в течение которых
проводилось наблюдение n (1 ≤ n ≤ 31), затем для каждого дня вводится
температура. python!

Эвелишка11 Эвелишка11    3   01.10.2019 21:30    31

Ответы
dkv1 dkv1  01.10.2019 22:20
Var a: array[1..31]of integer;
n,s,i,k: integer;
begin
s: =0;
k: =0;
writeln(введите кол-во дней);
readln(n);
for i: =1 to n do
begin
readln(a[i]);
s: =s+a[i];
if a[i]> 0 then k: =k+1;
end;
s: =s/n;
writeln(средняя температура,s);
if k> =5 then writeln(yes) else writeln(no);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика