Напишите программу для решения следующей .девятиклассники участвовали в викторине по . необходимо было ответить на 20 вопросов. победителем викторины считается участник, правильно ответивший на наибольшее количество вопросов. на сколько вопросов победитель ответил правильно? если есть участники викторины, которые не смогли дать правильный ответ ни на один из вопросов, выведите yes, иначе выведите no. гарантируется, что есть участники, правильно ответившие хотя бы на один из вопросов.программа получает на вход число участников викторины n (1 ≤ n ≤ 50), затем для каждого участника вводится количество вопросов, на которые получен правильный ответ. пример работы программы: входные данные 4 15 12 0 17 выходные данные 17 yes

Lubimka01 Lubimka01    2   11.09.2019 06:50    20

Ответы
thomsonrubi thomsonrubi  07.10.2020 07:09
Var
  N, i, max: shortint;
  arr: array[1..50] of shortint;
  v: string;

begin
  v := ' NO';
  max := -(MaxSmallInt);
  readln(N);
  for i := 1 to N do
  begin
    read(arr[i]);
    if arr[i] > max then max := arr[i];
    if arr[i] = 0 then v := ' YES';
  end;
  writeln(max, v);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика