Напишите программу для решения определить является ли данное число n чётным двухзначным числом

btsakhaev btsakhaev    1   03.08.2019 19:30    2

Ответы
соаовоых соаовоых  03.10.2020 20:47
Var
    n: integer;

begin
    readln(n);
    writeln((n mod 2 = 0) and (n div 10 > 0) and (n div 100 = 0));
end.
ПОКАЗАТЬ ОТВЕТЫ
Няшка1love Няшка1love  03.10.2020 20:47
Var
     n,
     check_n,
     : integer;
     flag : boolean;
Begin
     write('Введите чило');
     readln(n);
   
{Проверяется, является ли n четным}
     if n mod 2 = 0
          then
               flag = true;
          else
               flag = false;
     
{Проверяется, является ли n двухзначным}
     if n div 10 <> 0
          then
               flag = true;
          else
               flag = false;

     if flag
          then
                writeln('Число ', n, ' является четным двухзначным');
          else
               writeln('Число ', n, ' не является четным двухзначным');
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика