Напишите программу для решения квадратного уравнения вида ax^2+bx+c, где a не равно 0. примечание: если ваше условие выполняется и необходимо выполнение более одного действия, используйте для них конструкцию begin end, сохраняя оформление(сдвиг вправо). пример: if a> b then begin a: =b-1; writeln('a=',a); end else writeln ('b=',b); примечание: во всех предусмотрите очистку экрана при каждом запуске программы и задержку экрана, чтобы не нужно было нажимать alt+f5. а такое вначале на экране должна отображаться суть программы, не забывайте про грамотные диалоговые моменты.

MissKaprizz99 MissKaprizz99    1   28.07.2019 17:20    1

Ответы
Litegran Litegran  03.10.2020 15:47
Var a,b,c:real; 
begin 
readln(a); 
readln(b); 
readln(c); 
if (b*b-4*a*c)>=0 then writeln('deistvitelnie korni est!') else writeln('deistvitelnih korney net'); 
if (b*b-(4*a*c))>0 then begin writeln('2 kornya'); writeln('x1= ',(-b-sqrt(b*b-4*a*c))/(2*a)); writeln('x2= ',(-b+sqrt(b*b-4*a*c))/(2*a)) end; 
if (b*b-(4*a*c))=0 then begin writeln('1 koren'); writeln('x= ',(-b+sqrt(b*b-4*a*c))/(2*a)) end; 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика