Напишите программу для решения : дано целое неотрицательное число. определить количество нулей в его десятичной записи, на до на паскале, ! заранее .

bbb87 bbb87    1   21.05.2019 04:50    10

Ответы
stasyaukg stasyaukg  15.06.2020 02:46

Program noli;

Var X, Y: integer;

Begin

S:=0;

Write ('Введите число Х');

Read (X);

While X<>0 do begin

Y:= X mod 10;

If Y = 0 then S:= S + 1;

X:= X div 10;

Write ('Количество нулей в числе', S);

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика