Напишите программу для проверки таблицы умножения. перемножаются числа от 2 до 9 ( числа через датчик случайных чисел). количество вопросов не менее 10. можно предусмотреть подсчёта количества правильных и неправильных ответов. в паскаль!

ulviismailov13 ulviismailov13    1   21.09.2019 14:50    1

Ответы
ValeriaIv ValeriaIv  08.10.2020 07:21
//PascalABC.NET

begin
  var a,b,c:integer;
  var k:=0;
  for var i:=1 to 10 do
   begin
   a:=random(2,9);
   b:=random(2,9);
   write(a,'*',b,' = ');
   readln(c);
   if a*b=c then k:=k+1;
   end;
  writeln('Правильных ответов: ',k,', неправильных: ',10-k);
end.

Пример:
8*4 = 32
7*5 = 40
3*6 = 18
2*8 = 16
3*9 = 27
6*5 = 20
6*7 = 42
6*9 = 54
7*8 = 56
2*4 = 8
Правильных ответов: 8, неправильных: 2
ПОКАЗАТЬ ОТВЕТЫ
Tto2036 Tto2036  08.10.2020 07:21

program HelloWorld;

var i,res,ok: integer;

var a,b: integer;

begin

    ok:=0;

    for i:=1 to 2 do

    begin

        a:=2+random(7);

        b:=2+random(7);

        write('Сколько будет ');write(a);write(' умножить на ');write(b);writeln(' ?');

        readln(res);

        if res = a*b then ok:=ok+1;

    end;

    write('Правильных ответов:  ');writeln(ok);

   

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика