Напишите программу для подсчёта суммы и произведения вводимого числа​

Anya3456890 Anya3456890    2   16.11.2020 12:11    5

Ответы
venya09890 venya09890  16.12.2020 12:13

var

       sum, comp: Int64;

       i: Word;

       s: string;

       

begin

       Read (s);

       

       sum := 0;

       comp := Ord (s[1]) - 48;

       

       for i := 1 to Length (s) do

               sum := sum + Ord (s[i]) - 48;

       

       for i := 2 to Length (s) do

               comp := comp * Ord (s[i]) - 48;

               

       WriteLn ('Сумма цифр в числе ', s, ' = ', sum);    

       Write ('Произведение цифр в числе ', s, ' = ', comp);

end.


Напишите программу для подсчёта суммы и произведения вводимого числа​
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика