tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу для
Напишите программу для паскаля: для нахождения делителей числа n и их суммы с цикла while
hakimullinaale
3 01.06.2019 09:10
2
Ответы
013Angelina139
02.07.2020 14:48
Program s;
var d, n, s: integer;
begin
readln(n);
s:=0;
d:=1;
while(d<=n) do
begin
if(n mod d = 0) then
begin
s:=s+d;
writeln(d);
end;
d:=d+1;
end;
writeln(s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
IrinaZoloeva
07.04.2020 20:53
Информатика 5 класс Конспект по темам Решение задач по заданным правилам и Решение путём логических рассуждений , во к темам письменно...
alfard
07.04.2020 20:53
Очень нужна с exelСоставьте таблицу покупок: № товара, наименование товара, цена, количество, стоимость. 5%-ая скидка на покупку предоставляется в том случае, если стоимость...
Тьома11
07.04.2020 20:53
1. Дан массив целых чисел, состоящий из 15 элементов в диапазоне [-5,5]. Найти сумму всех элементов, расположенных на местах от х до y(х y) 2. Дан массив целых чисел, состоящий...
ЛолТролло
09.01.2021 15:15
Практические задания 1. На каждой странице создать гиперссылку на следующую по тексту «Далее» и обратно по тексту «Назад». При переходе по тексту «Далее» страница должна...
solppoli
09.01.2021 15:09
1. Какие признаки объекта считаются существенными 9. Приведете 2-3 примера слов-омонимов, выражает 8. Приведете 2-3 примера слов-синонимов, выражали, 4. Вспомните, в каких...
kulisenok
10.06.2019 19:30
Примеры актуальной и достоверной информации...
GoldChery
12.07.2019 16:10
Дан треугольник авс прямая мn делит стороны ав и вс угол n=углу а, вс=12 см, nм=6см, с сn=4см,найти ас...
xDxzkaketodelat
12.07.2019 16:10
Через неподвижный блок перекинута нить,к концам которой прикреплёны грузы массой 400 г и 100 г.пренебрегая массой блока и нити,а также трением блока, определите модуль ускорения...
happycatcom
12.07.2019 16:10
Цинк ( 2 ) оксид формула за валентністю...
wwwlavor
12.07.2019 16:10
Почему если выпала обильная роса дождя не будет...
Популярные вопросы
Сөзді құрайтын тілдік бірлік деген не...
3
Выразить в основных единицах и расположите в порядке возрастания 200...
1
Как разделить столбиком 252 на чтоб получилось 16,8?...
2
Семейство ежей по дорожке прогуливалось семейство ежей. впереди шел старый...
3
Чем разнообразны живые организмы а) неравномерно распределяются по планете....
3
Вблюдце налито 21,6 г воды. известно, что в 3 г воды содержится 10 в...
3
На вектора: 1) если ab=0 2) ab=ba 3) ac=bc 4) ca=cb тогда что можно сказать...
3
Бир багытка караптурган агайын бул не?...
2
Запись в виде неправильной дроби 3 1/2, 5 2/3, 4 3/7, 2 9/10...
2
Преобразуйте в многочлен выражение: -b(b++7)(b^2-7b+49)...
3
var d, n, s: integer;
begin
readln(n);
s:=0;
d:=1;
while(d<=n) do
begin
if(n mod d = 0) then
begin
s:=s+d;
writeln(d);
end;
d:=d+1;
end;
writeln(s);
end.