tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу для паскаля!
Напишите программу для паскаля! дано натуральное число. найти число, получаемое удалением удалением из исходного всех цифр а.
Anasteysha4002
2 09.07.2019 18:00
2
Ответы
976Марина1111111111
07.09.2020 08:26
Var n,m,k,p,a:integer;
begin
write('n='); readln(n);
write('a='); readln(a);
m:=0;p:=1;
while n<>0 do
begin
k:=n mod 10;
if k<>a then begin m:=k*p+m; p:=p*10; end;
n:=n div 10;
end;
writeln('m=',m);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Tamik7895
25.02.2021 15:56
Построить блок схему Вводятся три разных числа. Найти, какое из них является средним (больше одного, но меньше другого)....
maskaasenkova
25.02.2021 15:56
Pascal.задать массив из вещественных чисел размерностью [1...15]. Циклически сдвинуть его на 2 позиции вправо. Сдвинутый массив упорядочить по возрастанию....
Amkissa
25.02.2021 15:55
25. Напишите программу, которая ищет среди целых чисел, принадлежа- щих числовому отрезку (100 000; 250 000), числа, которые можно предста-вить в виде произведения...
malinka151
25.02.2021 15:55
сделать информатику. Найдити значение выражения: А) 55 div 10+14 Б)205 mod 100+1 В)(32 mod 4+1)*24 div 5 Г)23 div 6*5 mod 3-1...
Ивангаййййййййй
13.09.2019 11:23
Определить, сколько раз слово did встречается в тексте. програму написать з процедурою...
bonchuk2009
05.08.2019 00:00
Чем похожи и чем различаются источники информации и приемники информации...
Map21
05.08.2019 00:00
Посчитать объём книги, если известно что в ней 300 стр на каждой стр 30 строк по 40 символов...
stqz
17.11.2020 17:06
Перевести десятичные числа в двоичную восьмеричную и шестнадцатеричную системы счисления дробь 0,625...
AndreyDixord
17.11.2020 17:06
Паскаль. 1. Дано слово S1. Получить слово S2, образованное четными буквами слова S1. 2. Дано предложение. Удалить из него все «,» и 3. Дано слово из 4 букв, которое...
Dezzy12
17.11.2020 17:07
Python программасында есепті жазып,мәнін тексеріп көріңдер!...
Популярные вопросы
Попробуй сам объяснить как выполнено деление (угалком) с 62 номер...
2
Найдитеплощадь ромба если его диагонали равны 14 и 6...
2
Определите,какую часть 34,98 составляет от числа 18. ответ записать...
1
Вмагазин 35 кг конфет. продали 30% всего количества . сколько конфет...
2
Ао- сербски брат, по- польски брот, б)по сербски клас, по польски...
1
Восстановите порядок слов в словообразовательной цепочке оглушить...
1
4a^5b^5: (0.5ab^3)^2*(3a^3b^2)^4 при a=-1 , при b=1...
2
Переведите : может вместить пять франций или девяносто девять бельгий...
2
Кроссворд небольшая пластина из мягкой глины...
3
Подскажите как отмечают день славянской письменности и культуры....
2
begin
write('n='); readln(n);
write('a='); readln(a);
m:=0;p:=1;
while n<>0 do
begin
k:=n mod 10;
if k<>a then begin m:=k*p+m; p:=p*10; end;
n:=n div 10;
end;
writeln('m=',m);
end.